Minimum Requirements - AEJuice

Pack Manager minimum requirements are:

  • Adobe After Effects CS6 or higher
  • Windows 7 or Mac OS X 10.7

We do not plan to add support for older versions.

 

More details:

  • After Effects versions that we DO support: CS6, CC, CC 2014, CC 2014.2, CC 2015.1, CC 2015.2, CC 2017, CC 2018, CC 2019.
  • After Effects versions that we DO NOT support: CS3, CS4, CS5, CS5.5 (there is no plug-in support for CS5.5 but the regular .aep file is available).